Known issues in Iceberg
Review known issues and technical limitations for Iceberg in Cloudera Data Warehouse on cloud version 2026.0.21.4-12
Known issues identified in the September 18, 2026 release
There are no new known issues identified in this release.
Known issues identified before the September 18, 2026 release
- CDPD-100780: Materialized view rebuild fails when stored using the Iceberg storage format
- Materialized view rebuild operations fail when the
materialized view is stored using the Iceberg storage format. This failure occurs due to a
defect in Hive during materialized view rebuilds, during which the rebuild process fails but
leaves behind a stale lock entry in the
MATERIALIZATION_REBUILD_LOCKStable. As a result, subsequent rebuild attempts fail because the existing lock entry prevents new rebuild operations from proceeding. - CDPD-101214: Semantic error in MERGE statements when using backticks with restricted keywords as column names
- Hive fails to run
MERGEstatements with backticks by using restricted keywords as column names. The query displays aSemanticExceptionerror during parsing, preventing successful execution of theMERGEoperation.
- CDPD-101742: Hive Iceberg snapshot expiration fails for ORC LZ4/LZO tables
- Hive fails to run queries on Iceberg tables stored in ORC
format with LZ4 or LZO compression when LLAP cache is enabled. The failure results in an
OWN_TASK_FAILUREstatus and vertex failures due to anUnsupportedOperationExceptionerror during ORC decompression. The snapshot expiration functionality itself works as expected and is not impacted. - DWX-14163: Limitations reading Iceberg tables in Avro file format from Impala
- The Avro, Impala, and Iceberg specifications describe some
limitations related to Avro, and those limitations exist in Cloudera. In addition to these, the
DECIMALtype is not supported in this release. - DWX-23400: Impala Iceberg DELETE statements hang when tuple cache is enabled
- When running a
DELETEstatement on an Iceberg table, the Impala query might hang and remain in aRUNNINGstate indefinitely. This issue occurs due to a logic error in the tuple cache that prevents specific join builds from closing correctly during union operations.
