Fixed issues
Review the fixed issues in the latest Cloudera Data Warehouse on cloud for service layer version 1.13.1-b44, Hive, Impala, and Hue runtime version 2026.0.21.4-12, and Trino runtime version 2026.0.24.0-37.
Fixed issues in Cloudera Data Warehouse on cloud
- DWX-23542: Environment activation is blocked in the UI when the validation API reports errors
- Previously,
when
you attempted to activate an environment in the Cloudera Data Warehouse UI, the
Activate Environment option was not displayed if the validation API
call returned an error message. This occurred because the UI treated validation API results as
blocking errors rather than informational guidance, preventing users from completing
environment activation.
This issue is now resolved.
- DWX-24246, DWX-24227: Environment activation and deactivation failures due to missing IAM permissions in restricted and reduced policy modes
- Previously, in Cloudera Data Warehouse environments using restricted policy
modes, environment lifecycle operations failed due to missing AWS IAM permissions in the
policy templates. Environment deactivation failed and entered a
DELETE_FAILEDstatus, causing the environment to transition toBad Health, because the requiredelasticfilesystem:DescribeReplicationConfigurationspermission was missing from therestricted-policy-managedARN-2.json5policy template during EFS teardown. Additionally, post-CloudFormation environment activation failed with anAccessDeniedExceptionerror because direct AWS SDK calls toeks:DescribeClusterwere missing from direct call policy statement, specifically ingocodeEksfor reduced permissions mode andgocodeEKSClusterfor restricted policy mode, having only been present in CloudFormation-scoped statements.This issue is now resolved. The
elasticfilesystem:DescribeReplicationConfigurationspermission andeks:DescribeClusterpermission are now included in the corresponding IAM policy statements (gocodeEksandgocodeEKSCluster) in thecdw-cloud-policiesrepository. - DWX-24007: Cloudera Data Warehouse fails to activate in AWS environments with strict tag policies
- Previously, environment tags were added to EC2 instances only after they were created.
Because tags were missing during creation, activation failed in AWS accounts that strictly
require tags at launch.
This issue is now resolved. Tags are now included directly in the CloudFormation launch templates. As a result, EC2 instances, root EBS volumes, and primary ENIs are properly tagged from the moment they are created.
Fixed issues in Hive on Cloudera Data Warehouse on cloud
- CDPD-110246: Submitting a large DAG fails when a session outlives its client
- Previously, when a Tez session stayed active longer than the client
that created it, submitting a large DAG on that session failed with a
FileAlreadyExistsExceptionerror. - CDPD-121752: IndexOutOfBoundsException when WHERE clause contains subqueries and correlated conditions
- Previously, queries with a WHERE clause containing IN or EXISTS subqueries along with correlated conditions failed with an unexpected error, causing the query to throw an exception.
- CDPD-66731: Hive Metastore query failure during Zero Downtime Upgrade
- Previously, during a Zero Downtime Upgrade (ZDU) from version 7.2.17
to 7.2.18, long-running queries such as INSERT INTO statements failed with
a
MetaExceptionerror. - CDPD-95582: Compaction cleanup failed with a PostgreSQL data type error
- Previously, when Hive used a PostgreSQL-backed metastore, transaction compaction cleanup could fail with a PostgreSQL error such as could not determine data type of parameter $4 because a compaction cleanup query passed a NULL parameter without an explicit SQL type.
- CDPD-88849: Self-join queries failed with an ambiguous table alias error
- Previously, a query that joined the same table with itself more than twice, including through views or common table expressions, failed during compilation with an Ambiguous table alias error, even though the used aliases were valid.
Fixed issues in Cloudera Data Explorer (Hue) on Cloudera Data Warehouse on cloud
- CDPD-23994: Table page in Data Explorer displays comparison error for columns with mixed data types
- Previously, when a table contained columns with mixed data types (such as strings and integers), the Autocomplete and Describe APIs failed during data sorting and comparison operations. As a result, the table page in Data Explorer displayed a <’ not supported between instances of 'str' and 'int' comparison error instead of displaying the table data. This issue is now resolved by correcting how the Autocomplete and Describe APIs handle and sort mixed data types, ensuring that the table page displays correctly without errors.
- CDPD-82506: Single-column CSV import failure in Data Explorer
- Previously, importing a CSV file containing only a single column in Data Explorer failed during the file format detection step. This prevented the data preview from displaying and disabled the submission process. This issue is now resolved by improving file format parsing and field name inference for single-column CSV files.
- CDPD-100816: Data Explorer File Browser workflow submission button failure
- Previously, the Submit button component in the Data Explorer File Browser application failed to function, which prevented submitting workflows. This issue is now resolved by restoring the required path reference dependency.
- CDPD-68779: Error while browsing S3 buckets or ADLS containers from the left-assist panel
- Previously, when attempting to browse S3 buckets or ADLS containers from the left-assist panel in Data Explorer without the required permissions, the system displayed the Failed to retrieve buckets:1:0: syntax error generic error message. This issue is now resolved. When RAZ is enabled, the left-assist panel now opens the home directory if the required permissions are available. In non-RAZ environments, the left-assist panel opens the path configured in the Data Explorer configuration file.
- DWX-24136: Trino query failure in Data Explorer
- Previously, running Trino queries in Data Explorer failed with a cannot use authentication with HTTP error on shared Virtual Warehouse instances. This issue occurred because service discovery fallback mechanisms built an incorrect Trino coordinator URL, which omitted required authentication credentials. This issue is now resolved.
Fixed issues in Impala on Cloudera Data Warehouse on cloud
There are no fixed issues in this release.
Fixed issues in Iceberg on Cloudera Data Warehouse on cloud
There are no fixed issues in this release.
Fixed issues in Trino on Cloudera Data Warehouse on cloud
- DWX-24070: Unintended injection of default Data Lake configurations blocks creation of external Iceberg and Hive connectors
- Previously, in Cloudera Data Warehouse, creating a new Iceberg or Hive
connector always automatically injected default Data Lake configurations, such as Ranger
policies and Kerberos settings. These default configurations are only required for the default
Hive or Iceberg connector created during Virtual Warehouse creation to access the default Data
Lake. When creating a connector to an external metastore, such as when using an Iceberg REST
catalog or Delta Lake integration, these hardcoded defaults could not be bypassed, preventing
the creation of REST-based or external catalog
connectors.
This issue is now resolved. Creating custom or external Iceberg and Hive connectors no longer includes default Data Lake configurations, enabling custom metastore and catalog setups.
- DWX-23907: Trino queries fail intermittently when reading data from Azure Blob File System (ABFS) storage
- Previously, Trino queries failed intermittently with errors such as Error opening
split, Azure service error reading file, or Azure service error
fetching properties for file. This occurred due to an Azure token throttling issue
within the Trino runtime.
This issue is now resolved.
